Kali ini saya akan bagi tips bagaimana cara agar si indihome ngga kena captcha google. Sebagaimana kita ketahui dialup pppoe pada indihome mendapatkan IP public dynamis. Artinya siapapun pelanggan indihome mendapatkan ip public secara acak. Nah, masalahnya kita terkadang mendapat dosa dari pelanggan dengan ip tertentu yangmana ip tersebut telah terindikasi spam oleh google. Nah, bagimana cara mengatasi hal ini ?
clue :
berikut scriptnya
:global countSpam
:global currentIP
:global iface 0pppoe0
:if ([:len [/ip dns cache all find where name="ipv4.google.com" ]] = 1 ) do={
:set countSpam ($countSpam +1)
:log error "Akses ke google kena spam"
}
:if (($countSpam >= 5) && ([:len [/ip dns cache all find where name="ipv4.google.com" ]] = 1 )) do={
:log error "generate ip baru"
:set countSpam 0
/in pppoe-client disable $iface
:delay 2;
/in pppoe-client enable $iface
/ip dns cache flush
:log warning "DNS Cache has cleaned!"
:delay 2;
:set $currentIP [/ip address get [find interface="$iface"] address]
:for i from=( [:len $currentIP] - 1) to=0 step=-1 do={
:if ( [:pick $currentIP $i] = "/") do={
:set currentIP [:pick $currentIP 0 $i]
}
}
:log warning $currentIP
:local router [/system identity get name]
:local time [/system clock get time]
:local date [/system clock get date]
:local voltage [/system health get voltage]
:local tegangan (. [:pick $voltage 0 2] . "," . [:pick $voltage 2 3] ." volt")
:local pesan ("[ $router ]%0A" ."GENERATE IP%0A$currentIP:81/userman%0AKENA SPAM pada : %0A" . $time .", ".$date. "%0AVoltase saat ini $tegangan.")
/tool fetch url="https://api.telegram.org/bot388921546:AAGn69QpCDuLSOQd3E3JtI5nhfUmg05hQys/sendMessage?chat_id=-203533762&text=$pesan" keep-result=no
}
perhatikan yang saya bold silahkan sesuaikan dengan nama pppoe-client pada router anda.
Berikut hasilnya :
clue :
- pertama tama, wajib anda minta ke petugas telkom untuk men-set modem sebagai bridge. (Hal ini dimaksudkan agar dapat generate ip baru dengan method disable / enable pppoe-client)
- kemudian dial-up pppoe di mikrotik
- selanjutnya, arahkan semua pelanggan ke dns gateway router mikrotik anda
- ketika ada pelanggan yang kena spam, maka terindikasi pada dns cache dengan cname ipv4.google.com
- buat indikasi dugaan spam itu menjadi beberapa iterasi. Di sini saya gunakan 5x pengecekan dengan durasi 20 detik di setiap perulangan yang disimpan pada variable environment script. Karena ada beberapa pc yang berbeda tidak kena spam.
- jika iterasi sudah ditempuh sebanyak 5x pengecekan maka lakukan generate ip
- selain itu untuk memantau ip public sudah saya sertakan pada tutorial kali ini
- let's go!
berikut scriptnya
:global countSpam
:global currentIP
:global iface 0pppoe0
:if ([:len [/ip dns cache all find where name="ipv4.google.com" ]] = 1 ) do={
:set countSpam ($countSpam +1)
:log error "Akses ke google kena spam"
}
:if (($countSpam >= 5) && ([:len [/ip dns cache all find where name="ipv4.google.com" ]] = 1 )) do={
:log error "generate ip baru"
:set countSpam 0
/in pppoe-client disable $iface
:delay 2;
/in pppoe-client enable $iface
/ip dns cache flush
:log warning "DNS Cache has cleaned!"
:delay 2;
:set $currentIP [/ip address get [find interface="$iface"] address]
:for i from=( [:len $currentIP] - 1) to=0 step=-1 do={
:if ( [:pick $currentIP $i] = "/") do={
:set currentIP [:pick $currentIP 0 $i]
}
}
:log warning $currentIP
:local router [/system identity get name]
:local time [/system clock get time]
:local date [/system clock get date]
:local voltage [/system health get voltage]
:local tegangan (. [:pick $voltage 0 2] . "," . [:pick $voltage 2 3] ." volt")
:local pesan ("[ $router ]%0A" ."GENERATE IP%0A$currentIP:81/userman%0AKENA SPAM pada : %0A" . $time .", ".$date. "%0AVoltase saat ini $tegangan.")
/tool fetch url="https://api.telegram.org/bot388921546:AAGn69QpCDuLSOQd3E3JtI5nhfUmg05hQys/sendMessage?chat_id=-203533762&text=$pesan" keep-result=no
}
perhatikan yang saya bold silahkan sesuaikan dengan nama pppoe-client pada router anda.
Berikut hasilnya :
0 komentar:
Post a Comment